PT-2018-2778

CVE-2018-11040

·

تاريخ النشر

2018-06-14

·

تاريخ التحديث

2026-10-08

الوصف من

CVSS 3.1
7.5
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions Spring Framework versions 5.0.x prior to 5.0.7 Spring Framework versions 4.3.x prior to 4.3.18 Spring Framework older unsupported versions
Description The issue allows web applications to enable cross-domain requests via JSONP (JSON with Padding) through AbstractJsonpResponseBodyAdvice for REST controllers and MappingJackson2JsonView for browser requests. When MappingJackson2JsonView is configured in an application, JSONP support is automatically ready to use through the jsonp and callback JSONP parameters, enabling cross-domain requests. This could potentially impact the confidentiality of protected information.
Recommendations For Spring Framework versions 5.0.x prior to 5.0.7, update to version 5.0.7 or later. For Spring Framework versions 4.3.x prior to 4.3.18, update to version 4.3.18 or later. For Spring Framework older unsupported versions, consider upgrading to a supported version. As a temporary workaround, consider disabling the MappingJackson2JsonView or restricting access to the jsonp and callback parameters to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-F26X-PR96-VW86
DLA-2635-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾