PT-2018-2983

CVE-2018-18445

·

تاريخ النشر

2018-10-05

·

تاريخ التحديث

2024-06-21

الوصف من

CVSS 3.1
7.8
عالية
المقاييسAV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Linux kernel versions 4.14.x through 4.18.x before 4.18.13
Description The issue is caused by faulty computation of numeric bounds in the BPF verifier, which permits out-of-bounds memory accesses. This is due to the mishandling of 32-bit right shifts by the adjust scalar min max vals function in kernel/bpf/verifier.c. The vulnerability can be exploited to elevate privileges.
Recommendations For Linux kernel versions 4.14.x through 4.18.x before 4.18.13, update to version 4.18.13 or later to resolve the issue. As a temporary workaround, consider restricting the use of the BPF verifier until a patch is available. Avoid using the adjust scalar min max vals function in the kernel/bpf/verifier.c file until the issue is resolved.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
ALT-PU-2018-2490
ALT-PU-2018-2502
ALT-PU-2018-2529
CESA-2019_0512
MGASA-2018-0417
MGASA-2018-0418
MGASA-2018-0419
OPENSUSE-SU-2018_3658-1
RHSA-2019:0512
RHSA-2019_0512
RHSA-2019:0514
RHSA-2019_0514
SUSE-SU-2018:3589-1
SUSE-SU-2018:3593-1
SUSE-SU-2018:3934-1
SUSE-SU-2018:3961-1
SUSE-SU-2018:4069-1
SUSE-SU-2018:4072-1
USN-3832-1
USN-3835-1
USN-3847-1
USN-3847-2
USN-3847-3
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾