PT-2018-3090
CVE-2019-3860
·
تاريخ النشر
2018-12-03
·
تاريخ التحديث
2026-10-14
الوصف من
CVSS 2.0
9.4
حرجةالمقاييسAV:N/AC:L/Au:N/C:C/I:N/A:C
Name of the Vulnerable Software and Affected Versions
libssh2 versions prior to 1.8.1
Description
An out of bounds read flaw was discovered in the way SFTP packets with empty payloads are parsed. A remote attacker who compromises a SSH server may be able to cause a Denial of Service or read data in the client memory. The vulnerability may allow a remote attacker to cause a denial of service or gain unauthorized access to protected information by connecting to a compromised SSH server.
Recommendations
For versions prior to 1.8.1, update to version 1.8.1 or later to resolve the issue. As a temporary workaround, consider restricting access to SSH servers until the update is applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾