PT-2018-3209
CVE-2018-16802
·
تاريخ النشر
2018-09-10
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 3.1
7.8
عاليةالمقاييسAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Artifex Ghostscript versions prior to 9.25
Description
The issue exists due to insufficient input validation in the Ghostscript software, which can allow an attacker to execute arbitrary code by supplying crafted PostScript. This is related to incorrect "restoration of privilege" checking when running out of stack during exception handling, specifically with the use of the "pipe" instruction.
Recommendations
For Artifex Ghostscript versions prior to 9.25, update to version 9.25 or later to resolve the issue. As a temporary workaround, consider restricting the use of crafted PostScript to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾