PT-2018-3466
CVE-2018-16540
·
تاريخ النشر
2018-08-23
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 3.1
7.8
عاليةالمقاييسAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions:
Artifex Ghostscript versions prior to 9.24
Description:
The issue is related to a use-after-free in copydevice handling when processing crafted PostScript files with the builtin PDF14 converter. This could allow attackers to crash the interpreter or potentially have other unspecified impacts. Exploitation of the vulnerability may enable an attacker to cause a denial of service using a specially crafted PostScript file.
Recommendations:
For versions prior to 9.24, update to version 9.24 or later to resolve the issue. As a temporary workaround, consider restricting the use of the builtin PDF14 converter until a patch is available. Avoid processing untrusted or specially crafted PostScript files with the affected converter to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾