PT-2018-3831
CVE-2018-5800
·
تاريخ النشر
2018-01-16
·
تاريخ التحديث
2022-01-29
الوصف من
CVSS 3.1
6.5
متوسطةالمقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
LibRaw versions prior to 0.18.7
Description
The issue is related to an off-by-one error within the
LibRaw::kodak ycbcr load raw() function in the internal/dcraw common.cpp component of the LibRaw library. This error can lead to a heap-based buffer overflow, causing a crash. The vulnerability can be exploited by a remote attacker to cause a denial of service.Recommendations
For versions prior to 0.18.7, update to version 0.18.7 or later to resolve the issue. As a temporary workaround, consider restricting the use of the
LibRaw::kodak ycbcr load raw() function until a patch is applied. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾