PT-2018-4570

CVE-2015-9259

·

تاريخ النشر

2018-03-31

·

تاريخ التحديث

2018-05-01

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Docker Notary versions prior to 0.1
Description The issue arises from the checkRoot function in gotuf/client/client.go, which fails to check the expiry of root.json files. This allows an attacker to produce update files that reference an old root.json file, even if a user creates a new root.json file after a key compromise.
Recommendations For Docker Notary versions prior to 0.1, update to version 0.1 or later to resolve the issue. As a temporary workaround, consider manually verifying the expiry of root.json files to minimize the risk of exploitation.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾