PT-2018-4717

CVE-2016-10538

·

تاريخ النشر

2018-05-31

·

تاريخ التحديث

2019-10-09

الوصف من

CVSS 2.0
4.9
متوسطة
المقاييسAV:N/AC:M/Au:S/C:N/I:P/A:P
Name of the Vulnerable Software and Affected Versions node-cli versions prior to 1.0.0 cli versions prior to 1.0.0
Description The issue arises from the insecure use of temporary files, specifically lock file and log file, which can be exploited by an attacker to overwrite any file the starting user has access to. This is due to the predictable nature of the temporary file names used by the affected versions of cli. An attacker can create a symbolic link at the location of one of these temporary file names, allowing them to arbitrarily write to any file that the user owning the cli process has permission to write to.
Recommendations For node-cli versions prior to 1.0.0, update to version 1.0.0 or later. For cli versions prior to 1.0.0, update to version 1.0.0 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-6CPC-MJ5C-M9RQ
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾