PT-2018-4731

CVE-2016-10553

·

تاريخ النشر

2018-05-31

·

تاريخ التحديث

2019-10-09

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions sequelize versions 2.1.3 and earlier
Description The issue concerns SQL injection when user input is passed into certain functions or statements, such as findOne or where: "user input". This allows for potential SQL injection attacks.
Recommendations Update to version 3.0.0 or later. If upgrading is not an option, ensure that all uses of where: "input" and findOne("input") are properly sanitized, such as by the use of a wrapper function.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-2V7Q-2XQX-F4Q5
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾