PT-2018-9239

CVE-2018-1000052

·

تاريخ النشر

2018-02-09

·

تاريخ التحديث

2020-08-24

الوصف من

CVSS 3.1
7.5
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions: fmtlib versions prior to 4.1.0
Description: The issue is related to a memory corruption problem that can cause a Denial of Service. It occurs when an invalid format specifier is used in the fmt::print() function, resulting in a SIGSEGV due to memory corruption. This can be exploited by specifying an invalid format specifier in the fmt::print() function.
Recommendations: For versions prior to 4.1.0, update to version 4.1.0 or later to resolve the issue. As a temporary workaround, consider validating format specifiers before passing them to the fmt::print() function to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾