PT-2018-9290

CVE-2018-1000111

·

تاريخ النشر

2018-03-13

·

تاريخ التحديث

2022-05-13

الوصف من

CVSS 3.1
5.3
متوسطة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N
Name of the Vulnerable Software and Affected Versions: Jenkins Subversion Plugin versions 2.10.2 and earlier
Description: An improper authorization issue exists that allows an attacker with network access to obtain a list of nodes and users. This is due to a problem in SubversionStatus.java and SubversionRepositoryStatus.java. The issue is resolved in version 2.10.3, where the class handling requests to "/subversion/" no longer extends the class handling requests to the "/search/" sub-path, causing such requests to fail.
Recommendations: For Jenkins Subversion Plugin versions 2.10.2 and earlier, update to version 2.10.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the /subversion/ endpoint and the SubversionStatus.java and SubversionRepositoryStatus.java classes until a patch is applied.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-W9GQ-8Q35-3JCC
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾