PT-2018-9325

CVE-2018-1000153

·

تاريخ النشر

2018-04-05

·

تاريخ التحديث

2022-05-14

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Jenkins vSphere Plugin versions 2.16 and older
Description A cross-site request forgery issue exists in the Jenkins vSphere Plugin that allows attackers to perform form validation related actions. This includes sending numerous requests to the configured vSphere server, potentially resulting in denial of service, or sending credentials stored in Jenkins with a known ID to an attacker-specified server, specifically through the "test connection" feature. The form validation methods in the affected versions did not require POST requests, contributing to the CSRF vulnerability.
Recommendations For Jenkins vSphere Plugin versions 2.16 and older, update to version 2.17 or later, which requires POST requests and appropriate user permissions for form validation methods, thereby mitigating the CSRF vulnerability.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-2G32-2J8W-2QGF
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾