PT-2018-9389

CVE-2018-1000221

·

تاريخ النشر

2018-08-20

·

تاريخ التحديث

2018-10-15

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions pkgconf versions 1.5.0 through 1.5.2
Description The issue is related to a Buffer Overflow in the dequote() function, which can return a 1-byte allocation if the initial length is 0, leading to a buffer overflow. This can be exploited via a specially crafted .pc file.
Recommendations For pkgconf versions 1.5.0 through 1.5.2, update to version 1.5.3 to resolve the issue.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
OPENSUSE-SU-2024:11174-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾