PT-2018-9541

CVE-2018-1000817

·

تاريخ النشر

2018-12-20

·

تاريخ التحديث

2022-05-13

الوصف من

CVSS 3.1
7.5
عالية
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions Asset Pipeline Grails Plugin versions prior to 2.14.1.1 Asset Pipeline Grails Plugin versions prior to 2.15.1 Asset Pipeline Grails Plugin versions prior to 3.0.6
Description The issue is related to Incorrect Access Control in Applications deployed in Jetty, which can result in the download of .class files and any arbitrary file. This can be exploited via a specially crafted GET request containing directory traversal from the assets-pipeline context.
Recommendations For versions prior to 2.14.1.1, update to version 2.14.1.1 or later. For versions prior to 2.15.1, update to version 2.15.1 or later. For versions prior to 3.0.6, update to version 3.0.6 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-W73Q-MC9G-J56X
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾