PT-2019-10057

CVE-2018-20356

·

تاريخ النشر

2019-06-10

·

تاريخ التحديث

2019-06-11

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions: Cesanta Mongoose Embedded Web Server Library versions 6.13 and earlier
Description: The issue is caused by a use-after-free vulnerability in the mg http free proto data cgi function call in mongoose.c, allowing for an invalid read of 8 bytes. This can lead to a denial of service, resulting in an application crash, or potentially allow for remote code execution.
Recommendations: For Cesanta Mongoose Embedded Web Server Library versions 6.13 and earlier, update to a version later than 6.13 to resolve the issue.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾