PT-2019-11982

CVE-2019-10669

·

تاريخ النشر

2019-09-09

·

تاريخ التحديث

2020-08-24

الوصف من

CVSS 3.1
7.2
عالية
المقاييسAV:N/AC:L/PR:H/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions LibreNMS versions prior to 1.48
Description A command injection issue exists due to improper filtering of user-supplied parameters in the html/includes/graphs/device/collectd.inc.php file. The mysqli escape real string function is used, which does not escape certain command line syntax characters, such as the backtick (). This allows an attacker to inject commands into the $rrd cmdvariable, which is executed via thepassthru()` function.
Recommendations For LibreNMS versions prior to 1.48, update to version 1.48 or later to resolve the issue. As a temporary workaround, consider restricting access to the collectd.inc.php file to minimize the risk of exploitation. Avoid using the $rrd cmd variable in the affected API endpoint until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾