PT-2019-12044

CVE-2019-10773

·

تاريخ النشر

2019-12-16

·

تاريخ التحديث

2026-10-07

الوصف من

CVSS 3.1
7.8
عالية
المقاييسAV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Yarn versions prior to 1.21.1
Description The package install functionality in Yarn can be exploited to create arbitrary symlinks on the host filesystem. This can be achieved by using specially crafted "bin" keys. Depending on the current user's permission set, existing files could be overwritten.
Recommendations For versions prior to 1.21.1, update to version 1.21.1 or later to resolve the issue. As a temporary workaround, consider restricting the package install functionality until the update is applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-5XF4-F2FQ-F69J
ALT-PU-2020-1415
ALT-PU-2020-1988
SNYK-JS-YARN-537806
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾