PT-2019-12971
CVE-2019-12829
·
تاريخ النشر
2019-06-15
·
تاريخ التحديث
2021-07-21
الوصف من
CVSS 3.1
7.5
عاليةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
radare2 versions prior to 3.5.1
Description
The issue is related to the mishandling of the RParse API, which can be exploited by remote attackers to cause a denial of service, resulting in an application crash, or possibly have other unspecified impacts. This is demonstrated by newstr buffer overflows during replace operations, affecting specific files such as libr/asm/asm.c and libr/parse/parse.c.
Recommendations
For versions prior to 3.5.1, update to version 3.5.1 or later to resolve the issue.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾