PT-2019-14649

CVE-2019-16377

·

تاريخ النشر

2019-09-23

·

تاريخ التحديث

2020-08-24

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions consul ruby gem versions prior to 1.0.3
Description The issue is related to Incorrect Access Control in the consul ruby gem. Specifically, when a controller checks multiple powers using :if or :except conditions, these conditions are applied to all power checks in that controller, leading to skipped power checks and potentially allowing unauthenticated access to certain controller actions.
Recommendations For consul ruby gem versions prior to 1.0.3, update to version 1.0.3 or later to resolve the issue. As a temporary workaround, consider reviewing and manually validating all power checks in controllers to ensure correct access control until the update can be applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-8JHX-9GF4-HHF5
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾