PT-2019-15119

CVE-2019-17383

·

تاريخ النشر

2019-10-09

·

تاريخ التحديث

2022-07-19

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions netaddr gem versions prior to 2.0.4 netaddr gem versions prior to 1.5.3
Description The issue is related to misconfigured file permissions in the netaddr gem for Ruby. When a gem is installed, it may result in 0777 permissions in the target filesystem.
Recommendations For versions prior to 1.5.3, update to version 1.5.3 or later. For versions prior to 2.0.4, update to version 2.0.4 or later.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-49PJ-69VF-C689
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾