PT-2019-18678

CVE-2019-7644

·

تاريخ النشر

2019-04-11

·

تاريخ التحديث

2020-08-24

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Auth0 Auth0-WCF-Service-JWT versions prior to 1.0.4
Description The issue allows an attacker to forge an arbitrary JWT token that will be accepted by the vulnerable application if the error message containing the expected JWT signature is presented to them. This occurs when the application cannot successfully validate the JWT signature.
Recommendations For versions prior to 1.0.4, update to version 1.0.4 or later to resolve the issue. As a temporary workaround, consider restricting access to error messages that contain sensitive information such as the expected JWT signature.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-QPVX-GPQM-G98J
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾