PT-2019-18805
CVE-2019-7885
·
تاريخ النشر
2019-08-02
·
تاريخ التحديث
2022-05-24
الوصف من
CVSS 3.1
8.8
عاليةالمقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Magento 2.1 versions 2.1.0 through 2.1.17
Magento 2.2 versions 2.2.0 through 2.2.8
Magento 2.3 versions 2.3.0 through 2.3.1
Description
The issue is related to insufficient input validation in the config builder of the Elastic search module, which could lead to remote code execution. This could be exploited by an authenticated user with the ability to configure the catalog search.
Recommendations
For Magento 2.1 versions 2.1.0 through 2.1.17, update to version 2.1.18 or later.
For Magento 2.2 versions 2.2.0 through 2.2.8, update to version 2.2.9 or later.
For Magento 2.3 versions 2.3.0 through 2.3.1, update to version 2.3.2 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾