PT-2019-3586

CVE-2019-3863

·

تاريخ النشر

2019-03-18

·

تاريخ التحديث

2026-10-14

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions libssh2 versions prior to 1.8.1
Description A flaw in libssh2 allows a server to send multiple keyboard interactive response messages with a total length greater than the maximum unsigned char characters. This can cause an out of bounds memory write error. The issue is related to a buffer overflow in memory, which can be exploited by a remote attacker to cause a denial of service, execute arbitrary code, or disclose sensitive information.
Recommendations For versions prior to 1.8.1, update to version 1.8.1 or later to resolve the issue. As a temporary workaround, consider restricting access to the libssh2 library until a patch is applied.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2019-1501
CESA-2019_0679
CESA-2019_1175
CESA-2019_1652
DLA-1730-1
DSA-4431-1
MGASA-2019-0139
OPENSUSE-SU-2019_1075-1
OPENSUSE-SU-2019:1109-1
OPENSUSE-SU-2019_1109-1
OPENSUSE-SU-2020:2126-1
OPENSUSE-SU-2020_2126-1
OPENSUSE-SU-2020:2129-1
OPENSUSE-SU-2020_2129-1
OPENSUSE-SU-2024:10999-1
RHSA-2019:0679
RHSA-2019_0679
RHSA-2019:1175
RHSA-2019_1175
RHSA-2019:1652
RHSA-2019_1652
RHSA-2019:1791
RHSA-2019:1943
RHSA-2019:2399
SUSE-SU-2019:0655-1
SUSE-SU-2019:13982-1
SUSE-SU-2019:13997-1
SUSE-SU-2020:3551-1
USN-5308-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾