PT-2019-4188

CVE-2019-8308

·

تاريخ النشر

2019-02-11

·

تاريخ التحديث

2021-05-06

الوصف من

CVSS 3.1
8.2
عالية
المقاييسAV:L/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Flatpak versions prior to 1.0.7 Flatpak versions 1.1.x Flatpak versions 1.2.x prior to 1.2.3
Description The issue is related to errors in handling file descriptors in the Flatpak application and environment management tool. Exploitation of this issue may allow an attacker to modify arbitrary executable files on the host side by running the apply extra script. The vulnerability exposes /proc in the apply extra script sandbox, which enables attackers to modify a host-side executable file.
Recommendations For Flatpak versions prior to 1.0.7, update to version 1.0.7 or later. For Flatpak versions 1.1.x, update to version 1.2.3 or later. For Flatpak versions 1.2.x prior to 1.2.3, update to version 1.2.3 or later. As a temporary workaround, consider restricting access to the apply extra script until a patch is available.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2019-1597
CESA-2019_0375
DSA-4390-1
OESA-2021-1149
OPENSUSE-SU-2019:2038-1
OPENSUSE-SU-2019_2038-1
RHSA-2019:0375
RHSA-2019_0375
SUSE-SU-2019:2185-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾