PT-2019-4692
CVE-2019-19319
·
تاريخ النشر
2019-04-09
·
تاريخ التحديث
2025-09-29
الوصف من
CVSS 2.0
6.8
متوسطةالمقاييسAV:L/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
Linux kernel versions prior to 5.2
Description
The issue is related to a use-after-free in the
ext4 xattr set entry function in fs/ext4/xattr.c, which can cause a slab-out-of-bounds write access. This can occur when a large old size value is used in a memset call after mounting a crafted ext4 image. The exploitation of this issue may allow a remote attacker to execute arbitrary code.Recommendations
For Linux kernel versions prior to 5.2, update to version 5.2 or later to resolve the issue.
At the moment, there is no information about additional mitigation measures for this vulnerability.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾