PT-2019-4832
CVE-2019-11039
·
تاريخ النشر
2019-05-26
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
9.4
عاليةالمقاييسAV:N/AC:L/Au:N/C:C/I:N/A:C
Name of the Vulnerable Software and Affected Versions
PHP versions 7.1.x through 7.1.29
PHP versions 7.2.x through 7.2.18
PHP versions 7.3.x through 7.3.5
Description
The issue is related to an out-of-bounds buffer read in the PHP interpreter, specifically affecting the
exif iif add value function and the iconv mime decode headers() function when parsing MIME headers due to integer overflow. This could allow a remote attacker to gain unauthorized access to information or cause a denial of service.Recommendations
For PHP versions 7.1.x through 7.1.29, update to version 7.1.30 or later.
For PHP versions 7.2.x through 7.2.18, update to version 7.2.19 or later.
For PHP versions 7.3.x through 7.3.5, update to version 7.3.6 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾