PT-2019-4921
CVE-2019-2791
·
تاريخ النشر
2019-07-16
·
تاريخ التحديث
2022-03-07
الوصف من
CVSS 2.0
5.5
متوسطةالمقاييسAV:N/AC:L/Au:S/C:P/I:P/A:N
Name of the Vulnerable Software and Affected Versions
MySQL Server versions 5.7.26 and prior
MySQL Server versions 8.0.16 and prior
Description
The issue is related to inadequate access control in the MySQL Server component, specifically in the Server: Audit Plug-in subcomponent. It allows a high-privileged attacker with network access via multiple protocols to compromise the MySQL Server. Successful attacks can result in unauthorized update, insert, or delete access to some of the MySQL Server's accessible data, as well as unauthorized read access to a subset of the MySQL Server's accessible data. The vulnerability can also cause a hang or frequently repeatable crash (complete DOS) of the MySQL Server.
Recommendations
For MySQL Server versions 5.7.26 and prior, update to a version later than 5.7.26 to resolve the issue.
For MySQL Server versions 8.0.16 and prior, update to a version later than 8.0.16 to resolve the issue.
As a temporary workaround, consider restricting network access to the MySQL Server to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾