PT-2019-5184

CVE-2019-18676

·

تاريخ النشر

2019-11-14

·

تاريخ التحديث

2026-10-21

الوصف من

CVSS 3.1
8.5
عالية
المقاييسAV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Squid versions 3.x through 4.8
Description An issue was discovered due to incorrect input validation, resulting in a heap-based buffer overflow that can cause Denial of Service to all clients using the proxy. The severity is high because this issue occurs before normal security checks, allowing any remote client that can reach the proxy port to perform the attack via a crafted URI scheme.
Recommendations For Squid versions 3.x through 4.8, update to a version later than 4.8 to resolve the issue. As a temporary workaround, consider restricting access to the proxy port to minimize the risk of exploitation.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALSA-2020:4743
ALT-PU-2020-1479
ALT-PU-2020-1494
CESA-2020_4743
CLSA-2026-1776878817
DLA-2278-1
DSA-4682-1
MGASA-2019-0382
OPENSUSE-SU-2019:2540-1
OPENSUSE-SU-2019_2540-1
OPENSUSE-SU-2019:2541-1
OPENSUSE-SU-2019_2541-1
RHSA-2020:4743
RHSA-2020_4743
RLSA-2020:4743
SUSE-SU-2019:2975-1
SUSE-SU-2019:3067-1
SUSE-SU-2020:0661-1
SUSE-SU-2020:14460-1
SUSE-SU-2022:14908-1
SUSE-SU-2022_14908-1
USN-4213-1
USN-4446-1
USN-4446-2
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾