PT-2019-5327

CVE-2019-12527

·

تاريخ النشر

2019-07-11

·

تاريخ التحديث

2024-06-15

الوصف من

CVSS 2.0
10
عالية
المقاييسAV:N/AC:L/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions Squid versions 4.0.23 through 4.7
Description The issue is related to a heap-based buffer overflow in the HttpHeader::getAuth function of the Squid proxy server. This occurs because Squid uses a global buffer to store decoded data when checking Basic Authentication, but it does not verify that the decoded length is not greater than the buffer. This can allow a remote attacker to cause a denial of service or execute arbitrary code. The vulnerability can potentially be exploited to execute code with the rights of the server process.
Recommendations For Squid versions 4.0.23 through 4.7, update to version 4.8 or later, which includes the fix for this issue. As a temporary workaround, consider restricting access to the HttpHeader::getAuth function until a patch is available. Avoid using the vulnerable function to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALSA-2019:2593
ALSA-2019_2593
ALT-PU-2019-2264
ALT-PU-2019-2271
CESA-2019_2593
DSA-4507-1
ELSA-2019-2593
MGASA-2019-0266
OPENSUSE-SU-2019:2540-1
OPENSUSE-SU-2019_2540-1
OPENSUSE-SU-2019:2541-1
OPENSUSE-SU-2019_2541-1
OPENSUSE-SU-2024:11403-1
RHSA-2019:2593
RHSA-2019_2593
RLSA-2019:2593
RLSA-2019_2593
SUSE-SU-2019:2975-1
USN-4065-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾