PT-2019-5880

CVE-2019-16774

·

تاريخ النشر

2019-12-12

·

تاريخ التحديث

2020-10-07

الوصف من

CVSS 3.1
9.8
حرجة
المقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions phpfastcache versions prior to 5.1.3
Description The issue is related to shortcomings in the deserialization mechanism of the PhpFastCache library. Exploitation of this issue may allow a remote attacker to access confidential data, compromise its integrity, and cause a denial of service. The vulnerability is associated with a possible object injection in the cookie driver.
Recommendations For versions prior to 5.1.3, consider using another driver, such as the "Files" (Filesystem) driver, as a temporary workaround until the issue is resolved. Update to version 5.1.3 or later, which enforces JSON conversion when deserializing to address the issue.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-484F-743F-6JX2
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾