PT-2019-5888
CVE-2019-19246
·
تاريخ النشر
2019-11-25
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 3.1
8.8
عاليةالمقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Oniguruma versions prior to 6.9.4
Description
The issue is related to a heap-based buffer over-read in the
str lower case match function within the Oniguruma library, which is used for regular expression processing. This can potentially allow a remote attacker to cause a denial of service.Recommendations
For Oniguruma versions prior to 6.9.4, update to version 6.9.4 or later to resolve the issue.
As a temporary workaround, consider restricting the use of the
str lower case match function in the Oniguruma library until a patch is available.قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾