PT-2019-6163
CVE-2019-20444
·
تاريخ النشر
2019-12-10
·
تاريخ التحديث
2026-10-08
الوصف من
CVSS 2.0
9.4
حرجةالمقاييسAV:N/AC:L/Au:N/C:C/I:C/A:N
Name of the Vulnerable Software and Affected Versions
Netty versions prior to 4.1.44
Description
The issue is related to the HttpObjectDecoder.java component in Netty, which lacks a check for the presence of a colon in HTTP headers. This could lead to incorrect syntax interpretation or be seen as an "invalid fold." The exploitation of this issue might allow a remote attacker to access and compromise confidential data.
Recommendations
For versions prior to 4.1.44, update to version 4.1.44 or later to resolve the issue. As a temporary workaround, consider restricting access to the HttpObjectDecoder.java component to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾