PT-2019-6283

CVE-2019-25031

·

تاريخ النشر

2019-09-11

·

تاريخ التحديث

2026-08-25

الوصف من

CVSS 2.0
7.1
عالية
المقاييسAV:N/AC:M/Au:N/C:N/I:C/A:N
Name of the Vulnerable Software and Affected Versions Unbound versions prior to 1.9.5
Description The issue is related to insufficient neutralization of special elements in a request, which can be exploited by a remote attacker to impact data integrity. This can occur upon a successful man-in-the-middle attack against a cleartext HTTP session, allowing configuration injection in the create unbound ad servers.sh script. Note that the vendor does not consider this a vulnerability of the Unbound software, as create unbound ad servers.sh is a community-contributed script that facilitates automatic configuration creation and is not part of the Unbound installation.
Recommendations For Unbound versions prior to 1.9.5, update to version 1.9.5 or later to resolve the issue. As a temporary workaround, consider restricting the use of the create unbound ad servers.sh script until the update is applied. Additionally, avoid using cleartext HTTP sessions to minimize the risk of man-in-the-middle attacks.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
ALT-PU-2019-3282
ALT-PU-2019-3287
DLA-2652-1
OPENSUSE-SU-2022:0176-1
OPENSUSE-SU-2022_0176-1
SUSE-SU-2022:0176-1
SUSE-SU-2022_0176-1
SUSE-SU-2022:0176-2
SUSE-SU-2022:0301-1
SUSE-SU-2022_0301-1
USN-4938-1
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾