PT-2020-12287
CVE-2020-10691
·
تاريخ النشر
2020-04-30
·
تاريخ التحديث
2026-10-10
الوصف من
CVSS 3.1
5.2
متوسطةالمقاييسAV:L/AC:L/PR:L/UI:N/S:C/C:N/I:L/A:L
Name of the Vulnerable Software and Affected Versions
ansible-engine versions 2.9.x prior to 2.9.7
Description
An archive traversal flaw was found in ansible-engine when running
ansible-galaxy collection install. When extracting a collection .tar.gz file, the directory is created without sanitizing the filename. An attacker could take advantage to overwrite any file within the system.Recommendations
For versions 2.9.x prior to 2.9.7, update to version 2.9.7 or later to resolve the issue. As a temporary workaround, consider restricting the use of
ansible-galaxy collection install until a patch is applied. Avoid extracting collection .tar.gz files from untrusted sources to minimize the risk of exploitation. وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾