PT-2020-12628
CVE-2020-11465
·
تاريخ النشر
2020-04-01
·
تاريخ التحديث
2021-07-21
الوصف من
CVSS 3.1
8.8
عاليةالمقاييسAC:L/AV:N/A:H/C:H/I:H/PR:L/S:U/UI:N
Name of the Vulnerable Software and Affected Versions
Deskpro versions prior to 2019.8.0
Description
An issue was discovered where the "/api/apps/*" endpoints failed to properly validate a user's privilege. This allows an attacker to control or install helpdesk applications and leak current applications' configurations, including those used as user sources for authentication. As a result, an attacker can forge valid authentication models that resemble any user on the system.
Recommendations
For versions prior to 2019.8.0, update to version 2019.8.0 or later to resolve the issue. As a temporary workaround, consider restricting access to the "/api/apps/*" endpoints to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾