PT-2020-13785
CVE-2020-13926
·
تاريخ النشر
2020-07-14
·
تاريخ التحديث
2020-07-27
الوصف من
CVSS 3.1
9.8
حرجةالمقاييسAV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions
Apache Kylin versions 2.0 through 3.0
Description
The issue allows for SQL injection attacks due to the concatenation and execution of Hive SQL in Hive CLI or beeline when building a new segment. Some parts of the HQL are from system configurations, which can be overwritten by certain REST API, making the SQL injection attack possible.
Recommendations
For Apache Kylin versions 2.0 through 3.0, upgrade to version 3.1.0 to resolve the issue. As a temporary workaround, consider restricting access to the REST API that can overwrite system configurations to minimize the risk of exploitation.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾