PT-2020-14329

CVE-2020-15271

·

تاريخ النشر

2020-10-26

·

تاريخ التحديث

2020-11-13

الوصف من

CVSS 4.0
9.3
حرجة
المقاييسAV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N
Name of the Vulnerable Software and Affected Versions lookatme versions prior to 2.3.0
Description The issue affects users who render untrusted markdown with lookatme, potentially allowing malicious shell commands to be automatically run on their system. This is due to the automatic loading of the built-in "terminal" and "file loader" extensions in affected versions.
Recommendations For versions prior to 2.3.0, upgrade to version 2.3.0 or above. As a temporary workaround, consider manually deleting the lookatme/contrib/terminal.py and lookatme/contrib/file loader.py files. It is also recommended to be aware of what is being rendered with lookatme to minimize potential risks.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-C84H-W6CR-5V8Q
PYSEC-2020-61
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾