PT-2020-18338

CVE-2020-5242

·

تاريخ النشر

2020-02-20

·

تاريخ التحديث

2020-02-26

الوصف من

CVSS 2.0
9.3
عالية
المقاييسAV:N/AC:M/Au:N/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions openHAB versions prior to 2.5.2
Description The issue allows a remote attacker to use REST calls to install the EXEC binding or EXEC transformation service and execute arbitrary commands on the system with the privileges of the user running openHAB. Starting with version 2.5.2, all commands need to be whitelisted in a local file which cannot be changed via REST calls.
Recommendations For versions prior to 2.5.2, update to version 2.5.2 or later to ensure that commands are whitelisted in a local file and cannot be changed via REST calls. As a temporary workaround, consider restricting access to the REST API to minimize the risk of exploitation.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-W698-693G-23HV
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾