PT-2020-19644

CVE-2020-7596

·

تاريخ النشر

2020-01-25

·

تاريخ التحديث

2022-05-24

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions Codecov npm module versions prior to 3.6.2
Description The issue allows remote attackers to execute arbitrary commands via the gcov-args argument. This enables attackers to potentially gain control over the system.
Recommendations For versions prior to 3.6.2, update to version 3.6.2 or later to resolve the issue. As a temporary workaround, consider restricting access to the gcov-args argument to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-MH2H-6J8Q-X246
SNYK-JS-CODECOV-543183
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾