PT-2020-19645

CVE-2020-7597

·

تاريخ النشر

2020-02-17

·

تاريخ التحديث

2020-02-20

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions codecov-node versions prior to 3.6.5
Description The issue allows remote attackers to execute arbitrary commands due to an incomplete fix of a previous problem. The value provided as part of the gcov-root argument is executed by the exec function within lib/codecov.js.
Recommendations For versions prior to 3.6.5, update to version 3.6.5 or later to resolve the issue. As a temporary workaround, consider restricting the input provided to the gcov-root argument to prevent arbitrary command execution until a patch is applied.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-5Q88-CJFQ-G2MH
SNYK-JS-CODECOV-548879
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾