PT-2020-20302

CVE-2020-8819

·

تاريخ النشر

2020-02-25

·

تاريخ التحديث

2022-05-24

الوصف من

CVSS 3.1
8.1
عالية
المقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
Name of the Vulnerable Software and Affected Versions CardGate Payments plugin for WooCommerce versions through 3.1.15
Description The issue is related to a lack of origin authentication in the IPN callback processing function in cardgate/cardgate.php. This allows an attacker to remotely replace critical plugin settings, such as merchant ID and secret key, and bypass the payment process. For example, an attacker can spoof an order status by manually sending an IPN callback request with a valid signature but without real payment, and/or receive all of the subsequent payments.
Recommendations For CardGate Payments plugin for WooCommerce versions through 3.1.15, update to a version later than 3.1.15 to resolve the issue. As a temporary workaround, consider restricting access to the IPN callback processing function in cardgate/cardgate.php to minimize the risk of exploitation. Avoid using the IPN callback request with a valid signature but without real payment until the issue is resolved.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-5PQ5-9PHV-Q5J3
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾