PT-2020-2105

CVE-2019-15795

·

تاريخ النشر

2020-01-20

·

تاريخ التحديث

2022-05-24

الوصف من

CVSS 3.1
4.7
متوسطة
المقاييسAV:N/AC:H/PR:N/UI:R/S:C/C:L/I:L/A:N
Name of the Vulnerable Software and Affected Versions python-apt versions 1.9.0ubuntu1 and earlier
Description The issue is related to the incorrect verification of MD5 hash sums of downloaded files in the Version.fetch binary() and Version.fetch source() functions of the python-apt module. This could allow a remote attacker to compromise data integrity via a man-in-the-middle attack, potentially leading to the installation of altered packages.
Recommendations For python-apt version 1.9.0ubuntu1 and earlier, update to a fixed version such as 1.9.0ubuntu1.2, 1.6.5ubuntu0.1, 1.1.0~beta1ubuntu0.16.04.7, 0.9.3.5ubuntu3+esm2, or 0.8.3ubuntu7.5 to resolve the issue. As a temporary workaround, consider restricting the use of the Version.fetch binary() and Version.fetch source() functions until a patch is applied.
قابلية الاستغلال
إصلاح
التأثيرات
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-RP8M-H266-53JH
DLA-2074-1
DSA-4609-1
USN-4247-1
USN-4247-2
USN-4247-3
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾