PT-2020-2138
CVE-2020-11100
·
تاريخ النشر
2020-04-02
·
تاريخ التحديث
2026-09-18
الوصف من
CVSS 2.0
9.0
عاليةالمقاييسAV:N/AC:L/Au:S/C:C/I:C/A:C
Name of the Vulnerable Software and Affected Versions
HAProxy versions 1.8 through 2.1.4
Description
The issue is related to the hpack dht insert function in the HPACK decoder, which can be exploited by a remote attacker via a crafted HTTP/2 request. This could lead to writing arbitrary bytes around a certain location on the heap, possibly causing remote code execution. The vulnerability may allow an attacker to gain unauthorized access to confidential data, cause a denial of service, or impact data integrity.
Recommendations
For HAProxy versions 1.8 through 2.1.4, update to version 2.1.4 or later to resolve the issue.
As a temporary workaround, consider disabling HTTP/2 support until a patch is available.
Restrict access to the hpack dht insert function in the HPACK decoder to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾