PT-2020-21436

تاريخ النشر

2020-04-16

·

تاريخ التحديث

2020-04-16

الوصف من

CVSS 3.1
6.1
متوسطة
المقاييسAV:A/AC:H/PR:N/UI:N/S:C/C:H/I:N/A:N
Name of the Vulnerable Software and Affected Versions https-proxy-agent versions prior to 2.2.3
Description The issue allows an attacker with access to the proxy server to intercept unencrypted communications, which may include sensitive information such as credentials, by failing to enforce TLS on the socket if the proxy server responds to the request with a HTTP status different than 200.
Recommendations Upgrade to version 2.2.3 or 3.0.0.
قابلية الاستغلال
إصلاح
المورّدون
المنتجات المتأثرة
تصنيف نقاط الضعف
المعرّفات ذات الصلة
GHSA-PC5P-H8PF-MVWP
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾