PT-2020-3004
CVE-2020-14059
·
تاريخ النشر
2020-06-26
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 3.1
6.5
متوسطةالمقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H
Name of the Vulnerable Software and Affected Versions
Squid versions 5.x prior to 5.0.3
Description
The issue is related to errors in synchronization in the Ipc::Mem::PageStack::pop function of the Squid proxy server. Exploitation of this issue may allow a remote attacker to cause a denial of service. The problem occurs when processing objects in an SMP cache due to an ABA problem during access to the memory page/slot management list.
Recommendations
For Squid versions 5.x prior to 5.0.3, update to version 5.0.3 or later to resolve the issue. As a temporary workaround, consider restricting access to the vulnerable function Ipc::Mem::PageStack::pop until a patch is available.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾