PT-2020-5316
CVE-2020-1720
·
تاريخ النشر
2019-08-07
·
تاريخ التحديث
2026-09-18
الوصف من
CVSS 3.1
6.5
متوسطةالمقاييسAV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions
PostgreSQL versions prior to 12.2
PostgreSQL versions prior to 11.7
PostgreSQL versions prior to 10.12
PostgreSQL versions prior to 9.6.17
Description
A flaw was found in PostgreSQL's "ALTER ... DEPENDS ON EXTENSION", where sub-commands did not perform authorization checks. An authenticated attacker could use this flaw in certain configurations to perform drop objects such as function, triggers, et al., leading to database corruption.
Recommendations
For versions prior to 12.2, update to version 12.2 or later.
For versions prior to 11.7, update to version 11.7 or later.
For versions prior to 10.12, update to version 10.12 or later.
For versions prior to 9.6.17, update to version 9.6.17 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾