PT-2020-5441
CVE-2020-15709
·
تاريخ النشر
2020-08-03
·
تاريخ التحديث
2020-09-16
الوصف من
CVSS 3.1
5.5
متوسطةالمقاييسAV:L/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N
Name of the Vulnerable Software and Affected Versions
add-apt-repository versions prior to 0.98.9.2
add-apt-repository versions prior to 0.96.24.32.14
add-apt-repository versions prior to 0.96.20.10
add-apt-repository versions prior to 0.92.37.8ubuntu0.1~esm1
Description
The issue arises due to insufficient input validation in the add-apt-repository utility, allowing PPA owners to provide ANSI terminal escapes. This could modify terminal contents in unexpected ways, potentially compromising the integrity of protected information.
Recommendations
For versions prior to 0.98.9.2, update to version 0.98.9.2 or later.
For versions prior to 0.96.24.32.14, update to version 0.96.24.32.14 or later.
For versions prior to 0.96.20.10, update to version 0.96.20.10 or later.
For versions prior to 0.92.37.8ubuntu0.1esm1, update to version 0.92.37.8ubuntu0.1esm1 or later.
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾