PT-2020-6158

CVE-2020-7789

·

تاريخ النشر

2020-12-11

·

تاريخ التحديث

2020-12-21

الوصف من

CVSS 2.0
6.8
متوسطة
المقاييسAV:N/AC:M/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions node-notifier versions prior to 9.0.0
Description The issue allows an attacker to run arbitrary commands on Linux machines due to the options params not being sanitized when being passed an array. This could enable an attacker to execute malicious commands.
Recommendations For versions prior to 9.0.0, update to version 9.0.0 or later to resolve the issue. As a temporary workaround, consider sanitizing the options params when passing arrays to prevent arbitrary command execution.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-5FW9-FQ32-WV5P
RHSA-2021:0781
SNYK-JAVA-ORGWEBJARSNPM-1050371
SNYK-JS-NODENOTIFIER-1035794
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾