PT-2020-7861
CVE-2015-5334
·
تاريخ النشر
2020-01-23
·
تاريخ التحديث
2024-06-15
الوصف من
CVSS 2.0
7.5
عاليةالمقاييسAV:N/AC:L/Au:N/C:P/I:P/A:P
Name of the Vulnerable Software and Affected Versions:
LibreSSL versions prior to 2.3.1
Description:
The issue is caused by an off-by-one error in the OBJ obj2txt function, which can be triggered by a crafted X.509 certificate. This can lead to a denial of service (program crash) or potentially allow the execution of arbitrary code via a stack-based buffer overflow.
Recommendations:
For versions prior to 2.3.1, update to version 2.3.1 or later to resolve the issue. As a temporary workaround, consider restricting the processing of crafted X.509 certificates to minimize the risk of exploitation.
قابلية الاستغلال
استغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾