PT-2021-15435

CVE-2021-23326

·

تاريخ النشر

2021-01-20

·

تاريخ التحديث

2022-05-27

الوصف من

CVSS 3.1
8.8
عالية
المقاييسAV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H
Name of the Vulnerable Software and Affected Versions @graphql-tools/git-loader versions prior to 6.2.6
Description The issue allows for arbitrary command injection due to the use of exec and execSync in the load-git.ts file. This is a result of the package's design, which enables an attacker to inject malicious commands.
Recommendations For versions prior to 6.2.6, update to version 6.2.6 or later to resolve the issue. As a temporary workaround, consider restricting access to the load-git.ts file or disabling the use of exec and execSync functions until a patch is applied.
قابلية الاستغلال
إصلاح
التأثيرات
الباحثون
المورّدون
المنتجات المتأثرة
المعرّفات ذات الصلة
GHSA-VHHW-XJVF-WPRR
SNYK-JS-GRAPHQLTOOLSGITLOADER-1062543
وجدت خطأً في الوصف؟ لديك ما تضيفه؟ لا تتردد في مراسلتنا 👾